无名下载

聚合IT技术文章
开源代码资料下载站

ADO数据库操作模块

大小:13.834KB更新时间:2020-07-21

部分简介

.子程序 打开, 逻辑型, 公开, 使用表名或sql语句打开一个表,使用此命令前,必须用置连接()命令,先连接到数据库连接类,这是打开方式的第一种
.参数 命令文本, 文本型, , 本参数可以是SQL语句、数据表名。
.参数 命令类型, 整数型, , 1为SQL语句,,2为表名。
.参数 游标类型, 整数型, 可空, 可以被省略。可以为以下常量或数值之一:1、无游标;2、服务器端游标;3、客户端游标。如果此参数被省略,默认为 #客户端游标。

.如果 (是否为空 (游标类型))
置游标类型 (3)
.否则
置游标类型 (游标类型)
.如果结束
置游标位置 (3) ' 要加上这句,否则取记录数时会得到-1
ado_rs对象.写属性 (“LockType”, 3)
ado_rs对象.方法 (“Open”, 命令文本, , , , 命令类型) ' 最后 一个参数1为SQL语句,,2为表名。
.如果真 (ado_rs对象.读数值属性 (“State”, ) ≠ 0)
返回 (真)
.如果真结束
返回 (假)

.子程序 置连接并打开, 逻辑型, 公开, 置连接和打开一并处理,这是打开的第二种方式。
.参数 命令文本, 文本型, , 本参数可以是SQL语句、数据表名。
.参数 命令类型, 整数型, , 1为SQL语句,,2为表名。
.参数 数据库连接类, 数据库连接类, , 要连接到的数据库连接类
.参数 游标类型, 整数型, 可空, 默认为3(adOpenStatic),当如删除命令不好用时,可用1(键盘)或2(动态鼠标)代替 -1、#游标类型.未知0只读 — 不能改变数据1、#游标类型.键盘2、#游标类型.动态3、#游标类型.静态
.参数 锁定类型, 整数型, 可空, -1、#锁定类型.未明 1、#锁定类型.只读2、#锁定类型.悲观的3、#锁定类型.乐观的4、#锁定类型.批量乐观的 默认为2
.局部变量 b1, 变体型, , , souse
.局部变量 b2, 变体型

关闭 ()
.如果 (是否为空 (游标类型))
置游标类型 (3)
.否则
置游标类型 (游标类型)
.如果结束
置游标位置 (3) ' 要加上这句,否则取记录数时会得到-1
.如果真 (是否为空 (锁定类型))
锁定类型 = 2
.如果真结束
b1.赋值 (命令文本, )
b2.赋值 (数据库连接类.取连接对象本身 (), )
ado_rs对象.方法 (“Open”, b1, b2, 游标类型, 锁定类型, 命令类型) ' 最后 一个参数1为sql,2为表名
返回 (ado_rs对象.取错误 () = “”)

猜你喜欢

官方微信二维码 无名官方微信公众号