无名下载

聚合IT技术文章
开源代码资料下载站

授权文件生成器

大小:5.828KB更新时间:2020-08-08

部分简介

别人想使用你的软件的,只有授权文件才能打开软件,授权文件可以现在软件的使用时间。

使用次数或者其他的授权方式都可以自己修改。

选中文本 = 组合框1.取项目文本 (组合框1.现行选中项)
.如果真 (密码框.内容 = “”)
信息框 (“请输入一个有效数字”, #错误图标, “错误”)
密码框.获取焦点 ()
返回 ()
.如果真结束
.如果真 (到整数 (密码框.内容) > 1500)
信息框 (“请输入一个小于1500的数字”, #错误图标, “错误”)
密码框.获取焦点 ()
返回 ()
.如果真结束
.如果真 (天框.内容 = “”)
信息框 (“请输入一个有效数字”, #错误图标, “错误”)
天框.获取焦点 ()
返回 ()
.如果真结束
.如果真 (到整数 (天框.内容) > 1 且 组合框2.取项目数值 (组合框2.现行选中项) = 1)
信息框 (“试用天不能超过1天”, #错误图标, “错误”)
天框.获取焦点 ()
返回 ()
.如果真结束
.如果真 (到整数 (天框.内容) > 3 且 组合框2.取项目数值 (组合框2.现行选中项) = 2)
信息框 (“试用次数不能超过3次”, #错误图标, “错误”)
.如果真结束
试用 = 天框.内容
密码 = 密码框.内容
X5 = X1.内容 + “|” + X2.内容 + “|” + X3.内容 + “|5SnKey|6Date|7Bdcs|” + #引号 + 到文本 (组合框2.取项目数值 (组合框2.现行选中项)) + #引号 + “|” + 试用 + “|” + 密码 + #引号
调试输出 (X5)
.如果 (写到文件 (当前目录 + “key.” + 选中文本, 到字节集 (密码 + “ ~”) + 秘密 (到字节集 (X5), 密码, 1)) = 真)
信息框 (“写入成功。[key.” + 选中文本 + “]”, 0, “成功。”)
写配置项 (取当前目录 () + “\Config.ini”, “设置”, “授权文件”, “key.” + 选中文本)

猜你喜欢

官方微信二维码 无名官方微信公众号