无名下载

聚合IT技术文章
开源代码资料下载站

程序退出自动保存恢复文件例程

大小:2.669KB更新时间:2020-08-14

部分简介

.如果真 (读配置项 (取运行目录 () + “\AppYiWaiTest.ini”, “YiWai”, “Disabled”, “Yes”) = “No”) ' 判断上次用户操作编辑是退出是否有意外发生,如果有意外则提示是否恢复,否则正常进入!
.如果真 (信息框 (“您的程序因发生意外而终止,您是否想恢复自动备份的文件!”, #是否钮 + #询问图标, “是否恢复自动备份的文件”) = #是钮) ' 如果上次程序是意外关闭将询问和载入
编辑框.内容 = 到文本 (读入文件 (读配置项 (取运行目录 () + “\AppYiWaiTest.ini”, “YiWai”, “TempFile”, “”))) ' 恢复具体的内容
删除文件 (读配置项 (取运行目录 () + “\AppYiWaiTest.ini”, “YiWai”, “TempFile”, “”)) ' 恢复后把上次备份的文件删除
自动保存文件名 = 取临时文件名 () ' 为下次恢复起名
写配置项 (取运行目录 () + “\AppYiWaiTest.ini”, “YiWai”, “TempFile”, 自动保存文件名) ' 在配置项中记录备份文件的路径
写配置项 (取运行目录 () + “\AppYiWaiTest.ini”, “YiWai”, “Disabled”, “No”) ' 置初始状态为有变化发生
时钟.时钟周期 = 到数值 (组合框.内容) × 1000 ' 默认启动程序就自动做备份处理
返回 ()
.如果真结束

.如果真结束
删除文件 (读配置项 (取运行目录 () + “\AppYiWaiTest.ini”, “YiWai”, “TempFile”, “”)) ' 恢复后把上次备份的文件删除
自动保存文件名 = 取临时文件名 () ' 同上边相同命令
写配置项 (取运行目录 () + “\AppYiWaiTest.ini”, “YiWai”, “TempFile”, 自动保存文件名) ' 同上边相同命令
写配置项 (取运行目录 () + “\AppYiWaiTest.ini”, “YiWai”, “Disabled”, “No”) ' 同上边相同命令
时钟.时钟周期 = 到数值 (组合框.内容) × 1000
编辑框.内容 = 取重复文本 (100, “神2 - BoyChong - 谢栋!~~”) ' 临时代码,可删除

猜你喜欢

官方微信二维码 无名官方微信公众号