无名下载

聚合IT技术文章
开源代码资料下载站

易语言写OD插件转换置入代码

大小:9.678KB更新时间:2020-08-15

部分简介

txt = 取选择的代码文本 ()
.' 如果 (txt = “”)
' 信息框 (“没有内容。”, #错误图标, “错误”)
.否则
' bin = 十六进制文本到字节集_dtcser (txt)
' txt = 字节集_查看 (bin)
' 编辑框1.内容 = txt
' 置剪辑板文本 (txt)
' 信息框 (txt, #信息图标, “内容已复制至剪辑板中。”)

.如果真 (删全部空 (局部_分割文本 [i]) = “”) ' 判断是否没内容.如果没内容跳到循环尾
到循环尾 ()
.如果真结束
局部_每行内容 = 局部_分割文本 [i]
局部_每行内容 = 取文本右边 (局部_每行内容, 取文本长度 (局部_每行内容) - 8)
局部_每行内容 = 删首空 (局部_每行内容)
局部_每行二进制代码 = 取文本左边 (局部_每行内容, 16)
.如果 (局部_每行二进制代码 ≠ “”)
局部_每行二进制代码 = 子文本替换 (局部_每行二进制代码, “ ”, , , , 真) ' 过滤所有的空文本
局部_每行二进制代码 = 子文本替换 (局部_每行二进制代码, “:”, , , , 真) ' 过滤所有的:符号
局部_每行二进制代码 = 到小写 (局部_每行二进制代码) ' 过滤大写字母
.如果 (取文本长度 (局部_每行二进制代码) ÷ 2 = 取文本长度 (局部_每行二进制代码) \ 2) ' 判断长度是否为偶数
.计次循环首 (取文本长度 (局部_每行二进制代码) ÷ 2, i2)
局部_16进制文本 = 取文本中间 (局部_每行二进制代码, i2 × 2 - 1, 2)
.如果真 (取代码 (局部_16进制文本, 1) > 102)
信息框 (“格式可能出错!请检查”, 0, )
.如果真结束
局部_10进制文本 = 到文本 (十六转十 (局部_16进制文本))
.如果真 (局部_10进制文本 = “-1”)
跳出循环 ()
.如果真结束
局部_文本 = 局部_文本 + 局部_10进制文本 + “,”
.计次循环尾 ()
局部_文本 = 取文本左边 (局部_文本, 取文本长度 (局部_文本) - 1)
局部_文本 = “置入代码({” + 局部_文本 + “})'” + 局部_每行内容 + #换行符
编辑框2.加入文本 (局部_文本)
局部_文本 = “”
.否则
信息框 (“第” + 到文本 (i) + “行,长度不是偶数”, 0, )
返回 ()
.如果结束

.否则
信息框 (“第” + 到文本 (i) + “行,没取出二进制文本”, 0, )
返回 ()

猜你喜欢

官方微信二维码 无名官方微信公众号