无名下载

聚合IT技术文章
开源代码资料下载站

让自己的电脑变成服务器,远程文件传输器

大小:3.92KB更新时间:2020-08-15

部分简介

原理是设置通讯,服务器需要设定端口,客户端需要连接对象,得到文件信息,之后通过分割发送,加上些判断,能实时显示进度条等。

.判断开始 (服务器1.取回数据 () = 头)
按钮1.禁止 = 真
.判断开始 (是否在文件尾 (文件号, ) = 假)
.判断开始 (取文件长度 (文件号) - 取读写位置 (文件号) < 1000)
服务器1.发送数据 (客户, 头 + 读入字节集 (文件号, 取文件长度 (文件号) - 取读写位置 (文件号)), )
.判断 (取文件长度 (文件号) - 取读写位置 (文件号) ≥ 1000)
服务器1.发送数据 (客户, 头 + 读入字节集 (文件号, 1000), )
.默认

.判断结束
进度条1.位置 = 取读写位置 (文件号) ÷ 文件大小 × 100
输出调试文本 (到文本 (取读写位置 (文件号)))
.默认
关闭文件 (文件号)
.判断结束

.判断 (服务器1.取回数据 () = 头 + 头)
按钮1.禁止 = 假
信息框 (“发送完成”, 0, )

猜你喜欢

官方微信二维码 无名官方微信公众号