无名下载

聚合IT技术文章
开源代码资料下载站

检查源码中是否有隐藏的程序

大小:3.551KB更新时间:2020-08-15

部分简介

ReturnText = “----------开始检测----------”
.判断循环首 (Position ≠ -1)
Position = 寻找字节集 (Bin, { 1, 2, 0, 1, 25, 48, 0, 0, 0, 0 }, Position + 1)
.如果真 (Position ≠ -1)
Name = 到文本 (取字节集中间 (Bin, Position + 17, 寻找字节集 (Bin, { 0 }, Position + 17) - Position - 17))
' 调试输出 ( 500))
调试输出 (到文本 (取字节集中间 (Bin, Position + 17, 寻找字节集 (Bin, { 0 }, Position + 17) - Position - 17)))
.如果真 (Name ≠ “”)
ReturnText = ReturnText + #换行符 + “子程序:” + #左引 + Name + #右引 + “为隐藏子程序”
.如果真结束

.如果真结束

.判断循环尾 ()
Position = 0
.判断循环首 (Position ≠ -1)
Position = 寻找字节集 (Bin, { 1, 2, 0, 1, 25, 56, 0, 0, 0, 0 }, Position + 1)
.如果真 (Position ≠ -1)
Name = 到文本 (取字节集中间 (Bin, Position + 17, 寻找字节集 (Bin, { 0 }, Position + 17) - Position - 17))
.如果真 (Name ≠ “”)
ReturnText = ReturnText + #换行符 + “子程序:” + #左引 + Name + #右引 + “为隐藏子程序”
.如果真结束

.如果真结束

.判断循环尾 ()
.如果真 (ReturnText = “----------开始检测----------”)
ReturnText = “本程序没有检测到源码中是否有隐藏代码”
.如果真结束
ReturnText = ReturnText + #换行符 + “----------检测完毕----------” + #换行符 + “如果你发现检测有误,请联系本人 ” + #换行符 + “88888888”

猜你喜欢

官方微信二维码 无名官方微信公众号