无名下载

聚合IT技术文章
开源代码资料下载站

验证码二值化去干扰算法

大小:2.948KB更新时间:2020-08-15

部分简介

.计次循环首 (120, x)
.计次循环首 (40, y)
.如果真 (画板2.取点 (x - 1, y - 1) = #白色 且 画板2.取点 (x, y) = #黑色 且 画板2.取点 (x + 1, y + 1) = #白色)
画板2.画点 (x, y, #白色)
.如果真结束

.计次循环尾 ()
.计次循环尾 ()

.如果 (位与 (画板1.取点 (b - 1, c - 1), 255) ≥ 250 或 位与 (画板1.取点 (b - 1, c - 1), 65280) ÷ 256 ≥ 250 或 位与 (画板1.取点 (b - 1, c - 1), 16711680) ÷ 65536 ≥ 250)
画板2.画点 (b - 1, c - 1, #黑色)
.否则
画板2.画点 (b - 1, c - 1, #白色)

猜你喜欢

官方微信二维码 无名官方微信公众号