• 4873阅读
  • 35回复

[易语言]梦幻西游脚本E语言源码下载 [复制链接]

上一主题 下一主题
离线黑猫

 
发帖
2340

只看楼主 道具中心使用道具 楼主  发表于: 2012-03-11
.版本 2 iX&eQ{LB  
.子程序 __启动窗口_创建完毕 iX&eQ{LB  
提升进程权限 () iX&eQ{LB  
进程ID = 取进程ID (“my.exe”) iX&eQ{LB  
hwnd = 1903088 iX&eQ{LB  
.子程序 取小二坐标, 逻辑型 iX&eQ{LB  
.参数 坐标, 坐标型 iX&eQ{LB  
.局部变量 存储内存内容, 整数型, , "0" iX&eQ{LB  
.局部变量 读坐标_计次, 整数型 iX&eQ{LB  
输出调试文本 (十到十六 (小二坐标 - 116)) iX&eQ{LB  
.如果真 (取反 (小二坐标 = 0 或 读内存整数型 (进程ID, 小二坐标) = 0)) iX&eQ{LB  
    坐标.x = 读内存整数型 (进程ID, 小二坐标) ÷ 20 iX&eQ{LB  
    坐标.y = 四舍五入 ((1000 - 读内存整数型 (进程ID, 小二坐标 + 4)) ÷ 25, ) iX&eQ{LB  
    返回 (真) iX&eQ{LB  
.如果真结束 iX&eQ{LB  
内存搜索 (进程ID, 到字节集 (536871319), 存储内存内容) iX&eQ{LB  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) iX&eQ{LB  
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 4) = 读内存整数型 (进程ID, 十六到十 (“1151F48C”))) iX&eQ{LB  
        坐标.x = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 116) iX&eQ{LB  
        .如果真 (取反 (坐标.x = 0)) iX&eQ{LB  
            坐标.x = 坐标.x ÷ 20 iX&eQ{LB  
            坐标.y = 四舍五入 ((1000 - 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 120)) ÷ 25, ) iX&eQ{LB  
            小二坐标 = 存储内存内容 [读坐标_计次] + 116 iX&eQ{LB  
            返回 (真) iX&eQ{LB  
        .如果真结束 iX&eQ{LB  
    .如果真结束 iX&eQ{LB  
.计次循环尾 () iX&eQ{LB  
返回 (假) iX&eQ{LB  
.子程序 取驿站坐标, 逻辑型 iX&eQ{LB  
.参数 坐标, 坐标型, 可空 iX&eQ{LB  
.局部变量 存储内存内容, 整数型, , "0" iX&eQ{LB  
.局部变量 读坐标_计次, 整数型 iX&eQ{LB  
输出调试文本 (十到十六 (驿站坐标 - 116)) iX&eQ{LB  
.如果真 (取反 (驿站坐标 = 0)) iX&eQ{LB  
    坐标.x = 读内存整数型 (进程ID, 驿站坐标) iX&eQ{LB  
    坐标.y = 读内存整数型 (进程ID, 驿站坐标 + 4) iX&eQ{LB  
    返回 (真) iX&eQ{LB  
.如果真结束 iX&eQ{LB  
内存搜索 (进程ID, 到字节集 (536870914), 存储内存内容) iX&eQ{LB  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) iX&eQ{LB  
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 4) = 读内存整数型 (进程ID, 十六到十 (“1151F48C”))) iX&eQ{LB  
        坐标.x = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 116) iX&eQ{LB  
        坐标.y = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 120) iX&eQ{LB  
        驿站坐标 = 存储内存内容 [读坐标_计次] + 116 iX&eQ{LB  
        返回 (真) iX&eQ{LB  
    .如果真结束 iX&eQ{LB  
.计次循环尾 () iX&eQ{LB  
返回 (假) iX&eQ{LB  
.子程序 置驿站坐标 iX&eQ{LB  
.参数 x iX&eQ{LB  
.参数 y iX&eQ{LB  
写内存整数型 (进程ID, 驿站坐标, x) iX&eQ{LB  
写内存整数型 (进程ID, 驿站坐标 + 4, y) iX&eQ{LB  
.子程序 取人物坐标, 逻辑型 iX&eQ{LB  
.参数 坐标, 坐标型, 可空 iX&eQ{LB  
.局部变量 存储内存内容, 整数型, , "0" iX&eQ{LB  
.局部变量 读坐标_计次, 整数型 iX&eQ{LB  
' 输出调试文本 (十到十六 (人物坐标 - 168)) iX&eQ{LB  
.如果真 (取反 (人物坐标 = 0)) iX&eQ{LB  
    坐标.x = 读内存整数型 (进程ID, 人物坐标) iX&eQ{LB  
    .如果真 (取反 (坐标.x = 0)) iX&eQ{LB  
        坐标.y = 读内存整数型 (进程ID, 人物坐标 + 4) iX&eQ{LB  
        返回 (真) iX&eQ{LB  
    .如果真结束 iX&eQ{LB  
.如果真结束 iX&eQ{LB  
内存搜索 (进程ID, 到字节集 (#角色ID), 存储内存内容) iX&eQ{LB  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) iX&eQ{LB  
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 4) = 读内存整数型 (进程ID, 十六到十 (“1151F48C”))) iX&eQ{LB  
        坐标.x = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 168) iX&eQ{LB  
        坐标.y = 读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 172) iX&eQ{LB  
        人物坐标 = 存储内存内容 [读坐标_计次] + 168 iX&eQ{LB  
        人物像素坐标 = 存储内存内容 [读坐标_计次] + 116 iX&eQ{LB  
        返回 (真) iX&eQ{LB  
    .如果真结束 iX&eQ{LB  
.计次循环尾 () iX&eQ{LB  
返回 (假) iX&eQ{LB  
.子程序 取人物状态, 逻辑型 iX&eQ{LB  
.如果真 (人物坐标 = 0) iX&eQ{LB  
    取人物坐标 () iX&eQ{LB  
.如果真结束 iX&eQ{LB  
.如果真 (读内存整数型 (进程ID, 人物坐标 - 56) = 3) iX&eQ{LB  
    返回 (真) iX&eQ{LB  
.如果真结束 iX&eQ{LB  
返回 (假) iX&eQ{LB  
.子程序 取地图编号, 整数型 iX&eQ{LB  
.局部变量 存储内存内容, 整数型, , "0" iX&eQ{LB  
.局部变量 读坐标_计次, 整数型 iX&eQ{LB  
.如果真 (取反 (地图编号 = 0)) iX&eQ{LB  
    返回 (读内存整数型 (进程ID, 地图编号)) iX&eQ{LB  
.如果真结束 iX&eQ{LB  
内存搜索 (进程ID, 到字节集 (288056328), 存储内存内容) iX&eQ{LB  
.计次循环首 (取数组成员数 (存储内存内容), 读坐标_计次) iX&eQ{LB  
    .如果真 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] - 60) = 288056308) iX&eQ{LB  
        地图编号 = 存储内存内容 [读坐标_计次] + 60 iX&eQ{LB  
        返回 (读内存整数型 (进程ID, 存储内存内容 [读坐标_计次] + 60)) iX&eQ{LB  
    .如果真结束 iX&eQ{LB  
.计次循环尾 () iX&eQ{LB  
返回 (0) iX&eQ{LB  
附件设置隐藏,需要回复后才能看到!
离线殇情

只看楼主 沙发  发表于: 2012-03-12
谢谢分享~~~~~~~~~~~~~~~···
离线myredns

只看楼主 板凳  发表于: 2012-03-13
            
离线q846121931

只看楼主 地板  发表于: 2012-03-14
学习
离线zxccxzzxc

只看楼主 4楼 发表于: 2012-04-17
有意思~!!!!
离线xiao水滴

只看楼主 5楼 发表于: 2012-04-17
无名社区 —打造专业游戏论坛 取小二坐标 >>&~;PG[  
>>&~;PG[  
学习下 支持·······················
-------------------------
离线五渡

只看楼主 6楼 发表于: 2012-05-02
学习支持一下
离线supergirl520

发帖
11
只看楼主 7楼 发表于: 2012-05-08
学习学些。。。
离线hnscxh2012

只看楼主 8楼 发表于: 2012-05-28
强大,学学习习
离线deqdoff

只看楼主 9楼 发表于: 2012-06-04
Re:梦幻西游脚本E语言源码下载
快速回复
限80 字节
如果您在写长篇帖子又不马上发表,建议存为草稿
 
上一个 下一个